Como converter o ae86 para funcionar com a megasquirt ...

Esclarece aqui as tuas dúvidas relacionadas com esta centralina programável DIY
gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Como converter o ae86 para funcionar com a megasquirt ...

Mensagem por gon » 28 ago 2009, 11:11

boas pessoal.
deixa lá ver se consigo fazer me entender.

existem duas coisas essenciais para por um motor a funcionar ... faísca e gasolina.

começando pela gasolina:
quando alguém pensa em instalar uma centralina programável num 4age é porque normalmente a lista de alterações que o motor já tem não são suportadas pela centralina original.

Considerando que os injectores na centralina original já estão na casa dos 80%, diria que quando pensarem em instalar uma centralina programável provavelmente os injectores de origem também terão de ser substituídos. Se este for o caso, comprem uns de alta impedância (normalmente mais fáceis de encontrar e mais baratos, ate aos 180cv +/- os do supra atmosférico são uma boa opção, tem 1,5x mais capacidade, são das mesmas dimensões físicas e de alta impedância), vai vos facilitar bastante o trabalho ......

No caso de querem continuar com os de baixa impedância vão precisar de uma placa adicional para ajudar a megasquirt a lidar com eles.

http://www.jbperf.com/p&h_board/index.html

este senhor apenas vende a placa, os circuitos a serem montados teem de ser comprados ha parte e não se arranjam com facilidade em Portugal.
Para tal recomendo http://www.digikey.com/ .

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:11

Faisca

Aqui vem a parte controversa.

existem varias opções, mas vou apenas descrever as duas que acho melhores:

1ª usar o sistema EDIS da Ford.

Desvantagens: uma roda dentada com 36-1 dentes tem de ser soldada (ou aparafusada) ha polie da cambota, isto pode requer que o equilibrar da cambota tenha de ser refeito (ha quem diga que tem de ser feito, ha quem diga q não tem importância, não sei dizer ao certo...)

Vantagens: o distribuidor salta fora assim como a bobine, etc ... a faísca passa a ser bastante mais precisa (certamente já repararam quando estão com a pistola de ponto a tentar acertar nos 10 graus ha cambota que com o sistema de origem aquilo varia entre os 8 e os 12, não he muito preciso).
Quanto ha qualidade da faísca em si, a única coisa que posso dizer he que existem 4age turbo com mais de 300cv a correr este sistema sem problema.

Para adquirirem quer a roda dentada quer o sistema EDIS recomendo http://trigger-wheels.com/ he um site Inglês logo não pagam alfandegas ....

2º usar o sistema de origem + um ignitor de um 4age com MAF

Este he o processo que vou descrever (visto o EDIS estar muitíssimo bem referenciado pela net).
Em termos de hardware a unica coisa adicional que precisa he um ignitor de um 4age que venha equipado com MAF .
Para quem não sabe o ignitor he aquela peça quadrada que esta por cima da bobine (onde ligam os cabos de velas).
O ignitor dos carros de MAP ( ae86´s vendidos na Europa vem com este sistema) só tem uma ficha para ligações eléctricas.
Os de MAF ( os que he preciso adquirir) tem duas destas fichas verdes para conexões eléctricas.

Vantagem: simplicidade da instalação e também o aspecto original do cofre do motor pode ser mantido

Desvantagens: falta de precisão no disparo da faísca, nos carros atmosféricos não existe grande problema mas nos turbo ou compressor podem se notar algumas

Resumindo
Se o objectivo he o melhor sistema e o dinheiro não interessa ou se a cambota vai ser calibrada de qualquer das maneiras ... optem pelo EDIS.
Caso contrario começem por arranjar um ignitor de um 4AGE de MAF e mantenham se atentos a este post.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:11

Neste caso irei partir do principio que arranjaram uns injectores maiores e de alta impedância e que não vão calibrar a cambota mas comprar um ignitor MAF.

Hardware que vão precisar.
Megasquirt I V2.2 ou V3

Devido principalmente ha diferença de preço eu ainda compraria a v2.2
porque com o hardware da 2.2 consegue-se fazer tudo e mais alguma coisa q alguma vez poderão pensar em fazer com o 4age ....

No entanto se o objectivo he remover 2 dentes da roda de 24 do distribuidor para usar 12-1 (opção não falada anteriormente, mas possível apesar de as experiências que tive com esta opção não terem sido nada boas), então ai sim talvez compense a v3 devido ao conversor analogico-digital embutido (que a v2.2 não tem) .
No caso de EDIS a v2.2 também faz o serviço na perfeição

sites onde adquirir:

UK :
http://www.extraefi.co.uk/
ou então falem com o Bill "bill@shurvinton.fsworld.co.uk" ele não tem site, mas he um gajo impecável

USA :
http://www.diyautotune.com/
http://www.glensgarage.com
existem muitos outros em USA, mas estes dois são os que tenho experiência em trabalhar. O segundo é um pouco mais lento a despachar as encomendas

Sonda lambda Wideband com output analógico

as duas mais usadas são :

NGK Powerdex : um pouco mais cara mas trás mostrador incorporado o que pode ser uma vantagem

LC-1 da innovate : mais barata mas não trás manómetro (com manómetro sai mais cara que a NGK)

existem vários sites que vendem estes dois produtos (e o ebay também he uma opção neste caso)

UK :
http://www.extraefi.co.uk/
http://www.dataspares.com/acatalog/3769 ... ensor.html

USA :
http://www.diyautotune.com/
http://www.glensgarage.com
existem muitos outros em USA, mas estes dois sao os que tenho experincia em trabalhar. O segundo é um pouco mais lento a despachar as encomendas

ignitor de 4A-GE MAF
ebay ? amigos ?
oficialmente ninguém os vende, até porque já não se vendem novos (acho eu :P)

outros

ferro de soldar, pasta de soldar, manda termoretractil, fio eléctrico, etc.

mesmo que comprem a megasquirt já montada, terão de soldar alguns fios para a instalação (posso vir a oferecer este serviço se alguém achar que he algo demasiado difícil, no entanto vou tentar explicar o melhor que consigo)

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:12

primeira coisa a fazer he soldar a rosca para a sonda lambda no escape.
deve ser soldada assim que o tubo passa a ser só um ( originalmente começa em 4 depois passa para 2 depois 1 ) e a sonda deve sempre ser instalada com o fio virado para cima ( no relógio analógico isto he entre as 9:30 e as 2:30).
A sonda nunca deve andar montada se estiver desligada, com as sonda vem sempre a rosca e um tampão , se as ligações eléctricas da sonda ainda não estão feitas metam lá o tampão , nunca andem com a sonda no escape desligada .

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:13

segunda coisa a fazer he montar a centralina em si e testala com o stimulator no computador.

Se não estão confortáveis com o inglês ou com o ferro de soldar podem sempre encomendar estes item já montados.

a ultima fase he fazer as ligações eléctricas.
Existem dois sítios onde os trabalhos são maiores.


centralina, aqui vem ligar tudo aquilo que estive a falar.
A melhor maneira para mim he dessoldar o conector amarelo da centralina de origem e fazer um cabo que permita a megasquirt integrar com a cablagem original do carro

Imagem

no caso de terem medo de danificar a centralina de origem, pode sempre tentar arranjar uma no ferro velho com os conectores iguais, ou mesmo uma estragada ou algo do género.

a outra orçado he cortar a cablagem de origem e fazer ligação ha ficha da megasquirt, no entanto pode se tornar bastante confuso saber q fios vêem de onde depois deles terem sido tirados da ficha original.

podem também optar por substituir toda a cablagem, mas vai dar muito trabalho e dor de cabeça.


dois fios tem de ser alterados no ignitor de origem, para passar uma função para o ignitor MAF ( os dois ficam a funcionar no carro) isto são apenas dois fios que têm de ser redireccionados.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:13

e por agora he tudo.

o que vos falta saber he apenas que fios ligam onde, tanto no lado da centralina como no lado do ignitor.

Eu sei que era para fazer isto da ultima vez que tive em portugal, mas infelizmente tive um acidente em que parti o braço e foi me impossivel.
No entanto prometo fazer isto assim que voltar.

vou começar por ir metendo alguns fios que ainda me lembro, mas so vai estar completo quando eu estiver em portugal
.

Alguma coisa que esteja a faltar ?

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:14

post by ISAC

Além do que referiste, podias colocar os links directos para a montagem das placas v2.2/v3.0 e das alterações especificas para o 4a-ge.



De resto e por agora só tenho a dizer OBRIGADO :wink:

This is the assembly guide for the V2.2 main board
Assembling Your MegaSquirt® V3.0 Main Board
The MegaSquirt® Stimulator
Jamesl's Original 'MegaSquirting your MR2' Article
How to MegaSquirt your NA MKI Toyota MR2

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Tutorial : Megasquirting an European (MAP) AE86 (4age)

Mensagem por gon » 28 ago 2009, 11:15

This tutorial will hopefully help you to convert an ae86 to run on a MegaSquirt (MSnS)

Parts needed:
1. MS1 v2.2 (v3.0 can also be used with some deviation from this tutorial)
2. An igniter from a MAF 4age (these igniters have 2 wiring connectors instead of 1)
3. Stock wiring harness
4. You will also need soldering iron, wire, etc…..

If you never assembled a megasquirt I don’t recommend buying one already assembled.
Assembling a megasquirt gives you a notion about the different electronic components, and improves your ability with the soldering iron.

Assemble your megasquirt and make sure all is working (play around with the stim and the laptop)

With this procedure you are going to use the MAF igniter to condition the VR signal from the distributor in to the MS

This procedure has been done in 2 Portuguese AE86’s that have done several km over the last 3 years without a single glitch.

This procedure is an adaptation from the JamesL setup. (Thank you)
http://www.diyautotune.com/tech_article ... rt_122.htm


V2.2 board changes

Once you have the board assembled and tested with a Stim Kit, you have to modify the board to recognize the NE signal and generate a proper IGT pulse. To do this, you need to modify the MS input and output circuits. I used MS board V2.2 – these instructions are only good for that version of the board. I’m no electronic expert and used modifications recommended by James Murray, the developer of the MegaSquirt n Spark-Extra code.


To properly condition the input signal, you need to:
-- Remove D9
-- Install a 1k resistor between the right side (non-band) end of D5 and the right hole (banded) end of D9. (This provides a 12v pull-up on the input) (Note: I soldered the resistor to the leg of D5, about an 1/8th inch above the surface of the board.)

Imagem

Imagem

On the output side, assuming you’re using the FIDLE circuit for ignition control:
- Solder a 1k resistor between the left (non band) end of D9 and the small hole above D9. [Resistor can be 1k to 10k - it is a pull-up to +5V on the output to ignition.]

That’s it – the board should be ready to communicate with the Igniters.
Wiring

Wiring wise
there are 2 major things to be done:

1st
Patch cable …..

There are 3 ways to do this.
1. You can cut your wiring harness and solder the DB37 there
2. You can go to the scrap yard and find an old ECU with the same connector as yours and just use the connector.
3. You can remove the connector from the original ecu

The standard ECU has a code for each pin printed on the PCB ( ex : +B , VCC, NE, etc)

I will leave you with a list of them and where they should connect:


+B1 ;-; Switched battery source (hot both cranking and running). Goes to pin 28 on MS
+B ;-; Switched battery source (you can use it to feed your new wideband lambda sensor)
FC ;-; Fuel Pump relay. Goes to pin 37 on MS

E2 ;-; Main grounding circuits to engine block. – to MS pins on top row, 7-11,
THW ;-; coolant temp sensor – to MS pin 21
VTA ;-; variable throttle position sensor – to MS pin 22
VCC ;-; stable TPS signal for reference – to MS pin 26
THA ;-; air temperature sensor – to MS pin 20
IGF ;-; old ignition confirmation signal, now RPM input from MAF igniter – to MS pin 24
OX ;-; narrowband lamda – to MS pin 23 (if you have a wideband input the wideband signal to pin 23)
STH ;-; TVIS activation – to MS pin 31, if using X14 output. (Refer to JamesL setup for TVIS usage)

E1 ;-; Main grounding circuits to engine block. – to MS pins on top row, 7-11
IGT ;-; Ignition timing signal (from MS to MAP igniter) to MS pin 30 (using FIDLE output for ignition)
#20 ;-; circuit to injectors – to MS pins 33
#10 ;-; circuit to injectors – to MS pin 32
E01 ;-; Main grounding circuits to engine block. – to MS pins on top row, 7-11
E02 ;-; Main grounding circuits to engine block. – to MS pins on top row, 7-11


It might make your life easier if you check this 2 URL’s

http://club4ag.com/faq_and_tech_pages/E ... 04A-GE.htm

http://www.megamanual.com/v22manual/extwir.gif



2nd:
Igniters…..

Your MAF igniter should have 8 wires. From left to right they should be :
Black; yellow; brown; red; white; blue; green; black

Your MAP igniter (the one installed on the car) should have 6 wires. From left to right:
White; red; brown; brown; yellow; black

If you have these wiring colors on both your igniters continue, if not you might have to find out the pinout of your igniters.

First thing to do is to cut the White wire that comes from your MAP ignitor into the green connector (cut it at about halt it’s size) this wire is the ignition confirmation signal witch is not used in the megasquirt, we are going to use it to feed the MS with a conditioned distributor signal.

Next connect the green wire from the MAF igniter to the wire you just cut ( this way connecting the MAF green wire into the White wire on the connector plug )

Sorting out the +12v the brown wire that comes from the connector plug must connect to the + side of the coil, both brown wires on the MAP igniter and the brown wire on the MAF igniter.

Finally the red and white wire from the MAF igniter (the ones with a connecting plug of their own) should connect to distributor VR sensor (on the 4 tooth wheel, not the 24 one) to do this you need to cut the distributor wires and find a plug to connect them to the MAF igniter (the distributor connects to the wiring harness originally.)
Try not removing the distributor (assuming you had the timing set properly with the standard ECU you don’t want to change that, it bring another variable into the equation), removing the cover should be enough for you to see what wires come from what sensor, if later one you find out that the RPM signal is not so good you can remove the VR sensor from the 24 tooth wheel.

Resuming, the distributor 4 tooth VR signal sends a wave into the MAF igniter, this wave is then converted in to a square wave (digital) and delivered to the megasquirt. This gives megasquirt the RPM signal and engine position. The megasquirt then delivers the order to fire to the MAP igniter witch fires the coil.

It would be possible to use only the MAF igniter instead of using both, but they tend not to last very long.

Final notes

Bare in mind that the original injectors are low impedance, if your going to upgrade to bigger injectors I recommend getting high impedance ones.
If you do want to use low impedance injectors I recommend buying an injector driver board to assist the megasquirt with them. http://www.jbperf.com/p&h_board/index.html#Buy

This tutorial only covers some hardware. For TVIS activation and software configuration please refer to the JamesL setup.

http://www.diyautotune.com/tech_article ... rt_122.htm

As James says in is own tutorial:

This article is designed to provide general information on the setup I used. You should do your OWN RESEARCH before attempting this project. I AM NOT an expert on MegaSquirt or Toyota ignition systems. I’m just a guy that likes to play with cars……

Gonçalo Manuel gonae86 at gmail.com 23/08/2008 Portugal
Última edição por gon em 07 mai 2010, 21:12, editado 1 vez no total.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 28 ago 2009, 11:18

em relaçao ha sonda a resposta he sim, claro....
ligas do pino 23 ha tua wideband "nova"

em relaçao aos injectores
infelizmente a cablagem do nosso carro so permite que todos os injectores disparem de uma vez, visto todos estarem interligados (se medires com o multimetro podes confirmar isto)

a maneira como eu te disse deixa te um canal de injectores livre na megasquirt para futuras aplicaçoes

a maneira que tu descreveste liga tambem esse canal. no entanto ao fazeres desta maneira tens de ter cuidado em n meter a injecçao "alternated" porque se o fizeres vais ter o dobro das injecçoes, uma vez q a cablagem connecta os injectores todos entre si ......


se quiseres injecçao alternada tens de passar 4 fios novos , um para cada injector ...... em q ai tens 4 pinos na megasquirt e 4 injectores , logo he facil ( liga o 1(32) com o 4(33) e o 2(34) com o 3(35) (teoria discutivel :P ))
:)



isac Escreveu:Confirmo, o ECU é igual ao da imagem.

Duas dúvidas:
OX ;-; narrowband lamda – to MS pin 23 (if you have a wideband input the wideband signal to pin 23)
Sonda lambda liga ao pino 23 da megasquirt mas não ao OX do harness, visto que o nosso não trazia sonda lambda.
#20 ;-; circuit to injectors – to MS pins 33
#10 ;-; circuit to injectors – to MS pin 32
Não será #20 aos pinos 32/33 e #10 aos pinos 34/35. Apareceu-me esta dúvida ao consultar este link http://www.diyautotune.com/tech_article ... nector.jpg
jamesl Escreveu:“20” – circuit to injectors 1&2 – to MS pins 32 & 33 (I doubled up on the harness side)

“10” – circuit to injectors 3&4 – to MS pin 34 & 35 (ditto)
Tenho o cabo feito mas no final sugiram estas dúvidas (o OX é o cabo rosa - tenho de o cortar, certo?)

Imagem

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 17 set 2009, 16:09

Eu tenho a megasquirt montada como no exemplo em cima.

O que faz com que fique
FIDLE funtion = Spark output A
LED 17(D14) function = Squirt^^

Como é que altero para que fique assim?
FIDLE funtion = Idle control*
LED 17(D14) function = Spark output A

O motivo é que vou montar a bomba de ar e preciso do "Idle control". Pelo que li também tenho que meter o D9 no sítio. Importante?!

Será?

1º remover

"On the output side, assuming you’re using the FIDLE circuit for ignition control:
- Solder a 1k resistor between the left (non band) end of D9 and the small hole above D9. [Resistor can be 1k to 10k - it is a pull-up to +5V on the output to ignition.] "


2º adicionar

"Add 1K resistor from (-) of D17 to the right (5v) side of R23
Run a length of wire from D17 (-) to x11"


3º alterar

"IGT ;-; Ignition timing signal (from MS to MAP igniter) to MS pin 30 (using FIDLE output for ignition)"


para

"IGT ;-; Ignition timing signal (from MS to MAP igniter) to MS pin 25 (x11)"

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 18 set 2009, 10:57

O FIDLE circuit tens de voltar a por exactamente como estava e ligas lá a válvula de frio (n sei se tens de fazer algum circuito ou nao , procura no manual MSextra http://www.msextra.com/manuals/MS_Extra ... _Index.htm.

Para obteres spark do led17 precisas fazer o seguinte circuito

Imagem

atenção que maior parte dos componentes mencionados no circuito já estão na MS, apenas precisas adicionar uma resistência .....

pelo que me lembro (tenta perceber o esquema , n vá a minha memória ser mto fraca ) tens de soldar um fio ha perna do led (perna que está do lado da ficha de comunicações db9),

Imagem

depois soldas a resistência a um VCC de 5v (o pin8 do JP1 é um VCC de 5v). Depois unes o outro lado da resistência com o fio que vem do LED e soldas lá outro fio ( união de 3).

Imagem

Imagem

Imagem

Esse fio que te sobra he o teu spark output , podes ligar a um dos spare outputs da MS para o trazeres para a ficha db37.

X11 = pin 25 of 37pin db

X12 = pin 27 of 37pin db

X13 = pin 29 of 37pin db

X14 = pin 31 of 37pin db

Imagem

espero que n te esteja a induzir em erro porque já fiz isto ha bastante tempo e é difícil seguir circuitos sem a MS ha frente. Tenta confirmar por ti próprio.

Boa sorte :)
Última edição por gon em 07 mai 2010, 21:19, editado 1 vez no total.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 18 set 2009, 11:31

agora que leio o teu post com mais atencão reparo que estamos os dois a dizer basicamente a mm coisa ...
a unica dif he onde vais buscar os 5v VCC .....
tás lá :)

em relação ao D9, convém metelo onde estava sim

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 18 set 2009, 11:37

Gon, essa ilustração mostra o LED16 e não o LED17, será uma versão antiga da pcb? Deve de ser.


Input mods:

12v pullup na mesma?
-- Install a 1k resistor between the right side (non-band) end of D5 and the right hole (banded) end of D9. (This provides a 12v pull-up on the input) (Note: I soldered the resistor to the leg of D5, about an 1/8th inch above the surface of the board.)


Output mods:

"Add 4.7k resistor from (-) of D17/6 to the right (5v) side of R23/8
Run a length of wire from D17/6 (-) to x11 (spare)

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 18 set 2009, 11:39

gon Escreveu:agora que leio o teu post com mais atencão reparo que estamos os dois a dizer basicamente a mm coisa ...
a unica dif he onde vais buscar os 5v VCC .....
tás lá :)

em relação ao D9, convém metelo onde estava sim
Ainda tem uma diferença no meu post.
Tenho uma resistência de 1K e no teu é de 4.7K. A diferença é grande.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 18 set 2009, 14:37

sim , a imagem que meti he da V3 e nos temos a V2.2
quanto ha resistência , eles falam entre 1 e 10 .....acho q é mais ou menos ha escolha do freguês, no entanto podes tentar várias a ver se notas comportamentos diferentes .....
eu já n me lembro qual usei

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 16 mar 2010, 02:45

Fiz a alteração do Output mod com sucesso. Pelo menos funciona com o MegaStim!

No lugar do input mod meti o Díodo D9 onde vou ligar o FIDLE da 3 wire Stepper board da Glen Garage ao non-banded end of D9

Agora falta alterar o cabo que liga ao harness para que o sinal da ignição chegue ao pino 25 (x11). Confirmas?

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 04 abr 2010, 22:00

Gon vou tentar explicar o que me aconteceu por partes.

Fiz a alteração para funcionar em dual table. JP1-6 para X4.
Testei no stim e funciona


Alterei as ligações para utilizar o FIDLE com a bomba de ar. Fiz as seguintes alterações seguindo as indicações do Glen Hoag para utilizar a 3wire Stepper Board.

Código: Selecionar todos

D9 na placa

FIDLE           non-banded end of D9
ISV1             X13
ISV2             X12
+12V            Banded end of D14
Gnd              Banded end of D16

Idle valve

RSO     MS Pin 29
RSC     MS Pin 27

Vs      +12v (connect to same point that supplies MS pin 28)

Aproveitei e fiz a alteração para o spark output no LED 17.

Segui as indicações tuas e do manual

http://www.msextra.com/doc/ms1extra/MS_ ... l.htm#vast

Testado e a funcionar no stimulator.

Instalo o firmware de novo, tudo configurado como deve de ser, monto no carro, dou à chave e nada.

Primeira coisa que fiz foi confirmar os circuitos, saídas, más soldas, utilizei o voltímetro, testei a continuidade das fichas, etc., estava tudo ok mas nada funcionou.

Para despistar problemas, voltei a trás, passo a passo.

Removi o jumper para a dual table, configuro o software. Dou à chave, nada.
Removi a placa do Glen, configuro o software. Dou à chave, nada.
Voltei a testar o output x11 na pcb e no harness (pin 25), "tudo bem"... Dou à chave, nada.

Tinha faísca quando ligava a chave (aqueles dois "picos"), ganhava pressão na gasolina, mas depois não disparava mais, até ficarem as velas completamente encharcadas.

Voltei a montar tudo como estava - que trabalheira - Dou à chave, e pega à primeira.


Fiquei na m#$da.

O que mais queria era meter a funcionar a vávula de ar que já estava montada e a funcionar, mas como só consigo meter o carro a funcionar através do circuito Fast Idle fiquei sem saber o que fazer.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 05 abr 2010, 10:03

bem pelos vistos o teu unico problema he mesmo meter o led17 como spark output, o resto veio por acrescimo.
Estive a ler a primeira página deste topico e esta la tudo esplicado, dá me a ideia q estas no bom caminho.

Mudaste o LED14 function para "spark output A" ?
Que resistência usaste ? experimentas te outras ? no link q meteste falam em varias eu infelizmente n me lembro de qual usei.
Ve la se o pardal tem a ECU dele fora do sitio, crava lhe para ele tirar umas fotos e medir a resistência que sai do led14.

Diria q uma vez q metas o carro a trabalhar com o spark output A no led14 não vais ter mais problemas.
Estas a passar o spark output por um dos spares da DB-37 ? qual estas a usar? n te enganaste a soldar o fio e estas a usar um diferente ??

X11 = pin 25 of 37pin db

X12 = pin 27 of 37pin db

X13 = pin 29 of 37pin db

X14 = pin 31 of 37pin db

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 05 abr 2010, 22:06

O problema foi mesmo esse porque de resto funciona a dual table e o FIDLE.

Fiz a alteração na placa com a resistência de 1k e no software também (LED14 function para "spark output A"). Não experimentei mais nenhuma resistência porque não tinha. Não me lembrei de medir o valor e comparar a resistência no output... com a do FIDLE...

Sim, para ligar a placa que controla a válvula também tive que ligar aos spares e o LED14 foi direitinho para o x11, pino 25. Fiz teste de continuidade, vi se estava a fazer contacto com os pinos à volta, verifiquei tudo.

Eu uso o TunerStudio que tem a função para fazer registos (Trigger Logger) do sinal do módulo de ignição. Comparando o antes e o depois, (FIDLE para LED14) depois de fazer a alteração o sinal, ou melhor dizendo, as barras azuis que representam o "trigger", estavam quase no mínimo, um décimo do que aparecem usando o output pelo pin 30 (FIDLE).

André se estiveres a acompanhar este assunto, e estiveres com isso à mão para tirar fotos, ou fazer um comentário como está feito na tua PCB, dá uma ajuda.


Já soldei e tirei muita coisa na pcb, ela é frágil e não quero voltar a soldar novas "coisas" com medo de inutilizar a placa de vez e entrar em mais despesas.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 06 abr 2010, 08:02

pois, se estás com medo do "trial and error" vê la se cravas o pardal para medir a resistência , se não eu no principio do mês que vem vou estar em PT e posso te ver isso.

apardal
Site Admin
Mensagens: 632
Registado: 12 ago 2009, 17:13
Contacto:

Mensagem por apardal » 06 abr 2010, 16:43

Comigo não te safas facilmente. Estou cheio de trabalho, e a desmontagem da minha MS ainda dá algum trabalho!

Quanto à técnica da coisa, o gon é que tratou de tudo no meu. Pouco ou nada percebo das ligações

Boa sorte com isso Isac.

Cumprimentos

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 06 abr 2010, 17:38

Gon vou esperar que venhas. Entretanto vou macro fotografar a minha...

Avatar do Utilizador
juliocesar
Propietários
Mensagens: 85
Registado: 15 set 2009, 12:38
Contacto:

Mensagem por juliocesar » 14 abr 2010, 22:35

interessante ;)

Avatar do Utilizador
isac
Site Admin
Mensagens: 2483
Registado: 24 mai 2009, 11:59
Localização: Póvoa de Varzim
Contacto:

Mensagem por isac » 01 mai 2010, 18:12

gon Escreveu:... cravas o pardal para medir a resistência , se não eu no principio do mês que vem vou estar em PT e posso te ver isso.
Vou ter de cravar a ti!

Se tiveres tempo de ver o circuito avisa.

gon
Site Admin
Mensagens: 570
Registado: 30 abr 2009, 13:31
Contacto:

Mensagem por gon » 02 mai 2010, 14:55

ver se te vejo isto durante esta semana


  • Tópicos Semelhantes
    Estatísticas do Fórum:
    Última Mensagem

Quem está ligado:

Utilizadores neste fórum: Nenhum utilizador registado e 1 visitante